login about faq

Hi,

I got below error when trying to send mail using SendQ2.

The application is a 32bits classic ASP Web application running in MS Server 2008 R2 Standard 64bits OS.

Below is the error I got:

ChilkatLog:
SendQ2:
DllDate: Mar 11 2016
 ChilkatVersion: 9.5.0.56
 UnlockPrefix: anything for 30-day trial
 Username: KOS-IIS4:kosadmin
 Architecture: Little Endian; 32-bit
 Language: ActiveX
 VerboseLogging: 0
 createEmailForSending:
xSigningAlg: sha1
 Auto-generating Message-ID

smtp_from: kk123@kos.com
 smtp_recipients: kk123@kos.com
 SmtpHost: ex2-kos.com
 SmtpPort: 25
 SmtpSsl: 0
 StartTLS: 0
 SmtpQHeaders: x-sendMime: yes x-from: kk123@kos.com x-bounceAddr: kk123@kos.com x-recipients: kk123@kos.com x-smtpPort: COPcCJqYTCoLtnEAN1rAQ4aMmfL/M2/jZVX62XAD1tI= x-smtpHost: 9agChCj8myf0yrZv27eVW44pYbfJgTidTYNsMltrbSgzmzNswb3p19ujanKrkSx+ x-sendIndividual: yes x-startTls: no x-ssl: no x-autoGenMsgId: yes x-SMTPQ-Version: 9.5.0.56
 SendQFilename: D:\Temp\ChilkatSmtpQ\queue\e_20160601_081649_93f76b0012837D4FB.eml
 WindowsError: Access is denied.
 WindowsErrorCode: 0x5
 win32CreateFileAnsi failed.
 localFilePath: D:\Temp\ChilkatSmtpQ\queue\e_20160601_081649_93f76b0012837D4FB.eml
 currentWorkingDirectory: C:\Windows\SysWOW64\inetsrv
 localWindowsFilePath: D:\Temp\ChilkatSmtpQ\queue\e_20160601_081649_93f76b0012837D4FB.eml
 filename: D:\Temp\ChilkatSmtpQ\queue\e_20160601_081649_93f76b0012837D4FB.eml
 Failed to write complete file (7)
 Failed to write EML file.

asked Jun 01 at 04:24

mox123's gravatar image

mox123
3

edited Jun 01 at 10:26

jpbro's gravatar image

jpbro ♦
1.1k2618


Your server-side classic ASP does not have permission to create files in D:TempChilkatSmtpQqueue\

Create a virtual directory in IIS with the correct permissions, and then pass the virtual directory path to SendQ2.

link

answered Jun 02 at 09:46

chilkat's gravatar image

chilkat ♦♦
11.8k316358421

Thanks for reply.

The problem is finally solved. I found out the "Anonymous" authentication was not enabled for my web site and after enable it, the problem is solved.

link

answered Jun 02 at 21:47

mox123's gravatar image

mox123
3

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×98
×12

Asked: Jun 01 at 04:24

Seen: 252 times

Last updated: Jun 02 at 21:47

powered by OSQA