login about faq

Never received final reply on control channel The file IS sent, and CRC is correct, yet the error remains

    DllDate: Aug  5 2012
    UnlockPrefix: RAGSOFFTP
    Username: backlot:atomaton
    Architecture: Little Endian; 32-bit
    Language: ActiveX
    VerboseLogging: 0
    LocalFilename: C:\Tome\test\binarytest.nrg
    RemoteFilename: binarytest.nrg
      enabled: yes
      heartbeatMs: 5000
      sendBufferSize: 4096
    IdleTimeoutMs: 60000
    ReceiveTimeoutMs: 60000
    ConnectTimeoutSeconds: 60
    localFileSize: 2678620316
    initialGreeting: 220-Welcome to the backlot
220 All Actions are logged and monitored by a Chihuahua
    restartNext: 0
    ModeZ: 0
    BinaryMode: 1
    Passive transfer mode
    hostAddr: 173.55.xxx.xxx
      hostname: 173.55.xxx.xxx
      port: 1097
      ConnectTimeoutMs_1: 60000
      This is an IPV4 numeric address.
      Hostname to IP address resolution not needed.
          ai_flags: 4
          ai_family: 2
          ai_socktype: 1
          ai_protocol: 0
          ai_addrlen: 16
          ai_canonname: (NULL)
      Connecting to IPV4 address.
      ipAddress2: 173.55.xxx.xxx
      myPort_5: 3460
      connect successful (3)
    SetupPassiveDataSocket: Elapsed time: 0 millisec
    command: STOR 
    PutFilename: [binarytest.nrg]
    DataConnectionReady: Elapsed time: 0 millisec
    StorResponse: 150 Connection accepted
    ReceivedIntermediateResponse: Elapsed time: 0 millisec
    SendBufferSize: 4096
    Sending uncompressed...
    lastBytesSent: 000000004E455235000000009FA88000
    SentData: Elapsed time: 638828 millisec
    Timeout waiting to read socket or accept connection
    timeoutMs: 60000
    Failed to read FTP response line..
    FinalReply: Elapsed time: 60203 millisec
    IdleTimeoutMs: 60000
    NumBytesSent: 2678620316
    Failed to read 2nd STOR reply
    remoteFtpFile: binarytest.nrg
    TotalTime: Elapsed time: 699031 millisec

asked Oct 30 '12 at 22:08

rgibson1's gravatar image


edited Oct 30 '12 at 22:09

Try setting the SkipFinalReply property = true (or 1 if using the ActiveX).


answered Oct 31 '12 at 08:11

chilkat's gravatar image

chilkat ♦♦

Thanks for the quick reply, I saw that option somewhere and tried it already, but it did not work. Smaller files, up to large files work fine but >2GB files seem to have this problem. I have adjusted the buffer from 65K to 4K, extended the various revelant timeout's etc.


(Oct 31 '12 at 11:51) rgibson1

When you set SkipFinalReply = 1, did the PutFile method ignore it and still wait?

(Nov 01 '12 at 09:04) chilkat ♦♦

I will check that right now

(Nov 01 '12 at 11:17) rgibson1

I added two debug.print statements, one before and one after the call to putfile, now all is well ?? maybe Setting the SkipFinalReply value one call prior to calling putfile is too quick

If ThisSize > 2000000000 Then
   frmMain.ftp.SkipFinalReply = 1
   frmMain.ftp.SkipFinalReply = 0
End If
Debug.Print "Skip Value Before: " & frmMain.ftp.SkipFinalReply  ------ Only Added This
Success = frmMain.ftp.PutFile(srcfile, DstFile)
Debug.Print "Skip Value After: " & frmMain.ftp.SkipFinalReply   ------ And This
Debug.Print frmMain.ftp.LastErrorText
If (Success = 1) Then....

(Nov 01 '12 at 13:11) rgibson1
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Oct 30 '12 at 22:08

Seen: 1,975 times

Last updated: Nov 01 '12 at 13:11

powered by OSQA