login about faq

(Using the Chilkat .NET assembly for the 4.5 Framework (Visual Studio 2012)) The component works fine at my server. But when I publish the application and install it on another computer, it shows the following error:

“Could not load file or assembly ‘ChilkatDotNet45.dll” or one of its dependencies. The specified module could not be found.”

And “Details” shows:

“Exception Text System.IO.FileNotFoundException: Could not load file or assembly ‘ChilkatDotNet45.dll’ or one of its dependencies. The specified module could not be found.”

I have installed Microsoft .NET Framework 4.5 on the computer. And I use x64 build, and both computers use Win7 x64 OS.

I even tried to place ChilkatDotNet45.dll at various places but it did not help.

Any idea? Thank you!

asked Nov 01 '12 at 11:43

chilkat's gravatar image

chilkat ♦♦
11.8k316358420

I am having the same problem with the same DLL. I installed the Redistributables mention (both 32 and 64 show up in Control Panel ==> Programs and Features) but still get the same error when I compile and try to run the application... but only when I press a button that utilizes the module that uses Chiklat. When stepping through the code, I get the error as soon as I step into the line that accesses the method within the module.

(Jul 02 '13 at 13:59) MIkla

The problem is with the "dependency". The only dependency is the Visual C++ Redistributable for Visual Studio 2012. The Chilkat .NET assembly is a mixed-mode assembly, where the inner core is written in C++ and compiles to native code. There is a dependency on the VC++ runtime libs. Given that Visual Studio 2012 is new, it won't be already on most computers. Therefore, it needs to be installed. It can be downloaded from Microsoft here:

Visual C++ Redistributable for Visual Studio 2012

If using a .msi install for your app, it should also be possible to include the redist as a merge-module, so that it's automatically installed w/ your app if needed.

link

answered Nov 01 '12 at 11:46

chilkat's gravatar image

chilkat ♦♦
11.8k316358420

IMPORTANT NOTE: Starting with Chilkat version 9.5.0.46, two builds for .NET 4.5.* are available: One is compiled with VS2012 and therefore requires the VC++ 2012 redistributable. The other is compiled with VS2013 and requires the VC++ 2013 redistributable.

(Dec 06 '14 at 08:46) chilkat ♦♦

Note: Each version of Visual Studio corresponded to a new .NET Framework release:

VS2002 - .NET 1.0
2003 - .NET 1.1
2005 - .NET 2.0
2008 - .NET 3.5
2010 - .NET 4.0
2012 - .NET 4.5
The ChilkatDotNet45.dll is for the .NET 4.5 Framework, and therefore needs the VC++ 2012 runtime to be present on the computer.

Likewise, the ChilkatDotNet4.dll is for the 4.0 Framework and needs the VC++ 2010 runtime.

The ChilkatDotNet2.dll is for the 2.0/3.5 Frameworks and requires the VC++ 2005 runtime. (It is unlikely you'll find a computer that doesn't already have the VC++ 2005 runtime already installed.)

link

answered Aug 16 '13 at 10:59

chilkat's gravatar image

chilkat ♦♦
11.8k316358420

sir, do you know any rules/way to detect whether VC++ 2010 runtime already installed or not? because my installer don't have this function to check for that. so, which registry key or file need to check to verify whether vc++ 2010 is installed?

thanks in advance..

best regards

(Jul 17 '14 at 18:42) mAlam

nevermind, i have found the solution :)

(Jul 19 '14 at 04:07) mAlam

I am facing the same problem with Chilkat dll. We have .Net Framework 4.0 in VS 2012 Environment. I have VC++2012 both x86 as well as x64 Redistributable installed in my computer. Keep getting the error as “Could not load file or assembly ‘ChilkatDotNet45.dll” or one of its dependencies. The specified module could not be found.”

(Oct 21 '14 at 09:32) chilldll
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×62
×15
×14
×6
×3

Asked: Nov 01 '12 at 11:43

Seen: 24,100 times

Last updated: Dec 06 '14 at 08:46

powered by OSQA