login about faq

I'm getting the following error when trying to use the dll. I added the reference to my Web Forms Web Application:

Server Error in '/' Application. Could not load file or assembly 'ChilkatDotNet45' or one of its dependencies. An attempt was made to load a program with an incorrect format. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.BadImageFormatException: Could not load file or assembly 'ChilkatDotNet45' or one of its dependencies. An attempt was made to load a program with an incorrect format.

I don't understand what I'm doing wrong. Tried to deploy to Azure with .NET 4.5. And I'm developing on Windows 8 with .NET 4.5.

EDIT: One more thing I can add is my PC is a 64 bit, so I used the 64 bit library. Once I tried the 32 bit library I worked just fine. Setting on project were Any CPU.

asked Feb 14 '13 at 18:52

Sunsfallen's gravatar image

Sunsfallen
1223

edited Feb 15 '13 at 11:21


Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×98
×32
×12

Asked: Feb 14 '13 at 18:52

Seen: 8,183 times

Last updated: Feb 18 '13 at 08:19

powered by OSQA