login about faq

My project is using chilkat component working on development machine properly but when I am trying to run the same project on my virtual machine which is 32bit it didn't work. I have confirmed that chilkat.dll is in the bin folder along with the app.

The application gives error even when it is trying to execute the very first line of chilat component which is in my case **

Chilkat.Crypt2 crypt = new Chilkat.Crypt2();

**

On my development machine I have setup the target platform to 32 bit but even it is not working any idea or suggestion.

This is what I am getting in error

Problem signature: Problem Event Name: CLR20r3 Problem Signature 01: testing.exe Problem Signature 02: 1.0.0.0 Problem Signature 03: 512e7778 Problem Signature 04: Testing Problem Signature 05: 1.0.0.0 Problem Signature 06: 512e7778 Problem Signature 07: 4 Problem Signature 08: e Problem Signature 09: System.IO.FileNotFoundException
OS Version: 6.1.7601.2.1.0.768.2
Locale ID: 1033 Additional Information 1: 0a9e Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:Windowssystem32en-USerofflps.txt

Thanks Khurram

Update 1:

I ran the Framework verification tool as well as it has confirmed that all the .net frameworks are installed from 2.0 to 4.5 on Virtual machine Windows 7 Home Basic 32bit.

asked Feb 27 '13 at 16:22

Khurram's gravatar image

Khurram
11557

edited Feb 28 '13 at 04:40


I haven't got a clue on this one. My only guess is based on this string found in the error message: "CLR20r3". You tagged the post "chilkatdotnet4", so I'm assuming you're using the ChilkatDotNet4.dll? If so, that's for the .NET 4.0 Framework, but "CLR20r3" suggests that the .NET 2.0 Framework is required. The solution would be to use ChilkatDotNet2.dll

link

answered Feb 27 '13 at 17:31

chilkat's gravatar image

chilkat ♦♦
11.8k316358421

Thanks champ, let me try and get back to you.

(Feb 28 '13 at 03:54) Khurram

Ok, I downloaded and copied 32bit .NET chilkat dll from this link http://chilkatsoft.com/download/ChilkatDotNet2-9.4.0-win32.msi but no luck. Still giving the same error.

My development machine is using VS2010 and VS2012 and I build this test app on VS2012 using .NET 4.5 but 32bit platform target. The virtual machine is Windows 7 Home basic 32 bit and installed .NET 4.5 Framework only but still giving the same error ... please suggest

(Feb 28 '13 at 04:08) Khurram
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×18

Asked: Feb 27 '13 at 16:22

Seen: 1,315 times

Last updated: Apr 14 '13 at 22:27

powered by OSQA