login about faq

I have iOS6 project where I successfully use Chilkat libraries. I have added address book library called RHAddressBook to project (https://github.com/heardrwt/RHAddressBook) which seems very clean and high quality library.

The problem is that for it to be able to work, it needs "Other Linker Flags" in Build Settings set to "-all_load -ObjC". When I do that, Chilkat starts to give this linker error:

Undefined symbols for architecture armv7: "_res_9_query", referenced from: ChilkatResolve::mxLookup(char const, ScoredStrings&, LogBase&, bool) in libchilkatIos.a(ChilkatResolve.o) ChilkatResolve::dkimLookup(char const, StringBuffer&, LogBase&, bool) in libchilkatIos.a(ChilkatResolve.o) ChilkatResolve::bestMxLookup(char const*, StringBuffer&, LogBase&, bool) in libchilkatIos.a(ChilkatResolve.o) ld: symbol(s) not found for architecture armv7 clang: error: linker command failed with exit code 1 (use -v to see invocation)

Any ideas how to get around this?

asked Jun 19 '13 at 16:39

ilkkapirttimaa's gravatar image

ilkkapirttimaa
1333


Hi!

I got the same error. It has nothing to do with the linker flag "-ObjC". You have to include one or two additional linker flags as mentioned here: http://www.chilkatsoft.com/chilkatIos.asp Add "-lresolv" and "-lpthread" to your "Other Linker Flags" and your error will be gone.

Greetings, disy.

link

answered Jun 20 '13 at 03:21

disy's gravatar image

disy
26226

Great, problem solved.

(Jun 20 '13 at 14:02) ilkkapirttimaa
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×94
×3

Asked: Jun 19 '13 at 16:39

Seen: 1,691 times

Last updated: Jun 20 '13 at 14:02

powered by OSQA