login about faq

hi, i have issue, when importing chilkat under centos 6.4 64bit

import chilkat

File "/usr/lib64/python2.6/site-packages/chilkat.py", line 26, in <module> _chilkat = swig_import_helper() File "/usr/lib64/python2.6/site-packages/chilkat.py", line 22, in swig_import_helper _mod = imp.load_module('_chilkat', fp, pathname, description) ImportError: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib64/python2.6/site-packages/_chilkat.so)

anyone has any idea?

thanks

asked Sep 17 '13 at 03:52

michellejunlee's gravatar image

michellejunlee
16112


The Python 2.6 and Ruby 2.0 builds are ready: http://www.chilkatsoft.com/chilkat_glibc211.asp

link

answered Oct 07 '13 at 10:11

chilkat's gravatar image

chilkat ♦♦
11.8k316358420

The newest version of Chilkat (v9.4.1 SP1) requires glibc 2.15. Chilkat is working to provide something that will work with glibc 2.12, but this will take some time. In the meantime, the only solution is to drop back to the previous version which should be OK for glibc 2.12. To download the previous version (v9.4.0), just replace "9.4.1" with "9.4.0" in the download URL.

link

answered Sep 17 '13 at 10:47

chilkat's gravatar image

chilkat ♦♦
11.8k316358420

Same problem here :( and I could not be able to find the v9.4.0 download link

link

answered Sep 27 '13 at 19:55

Igor%20Escobar's gravatar image

Igor Escobar
11

edited Sep 27 '13 at 20:10

I installed the version 9.4.0 (its real version is 9.3.4). This version didn't worked with Ruby 2.0. There is stack trace of the error: http://pastebin.com/Dj7XF8u0

link

answered Sep 30 '13 at 09:43

Igor%20Escobar's gravatar image

Igor Escobar
11

To those who are waiting for answers:

"Dear Igor,

Thank you. Chilkat is working to provide builds for an older version of GLIBC that should satisfy this need. I will send email when it is ready, but it may take some time -- possibly a week.

Best Regards, Matt Fausey Chilkat Software, Inc."

link

answered Sep 30 '13 at 12:15

Igor%20Escobar's gravatar image

Igor Escobar
11

Thanksss!!

link

answered Oct 07 '13 at 10:14

Igor%20Escobar's gravatar image

Igor Escobar
11

I upgrade it to this version and now aes.UnlockComponent("anything for 30-day trial") is returning false. Before buying it I'm trying this library locally and on the same environment that it would be running in production... locally it's running perfectly but in production env isn't. There is any other way that to unlock the component and test it all the way before buying it?

link

answered Oct 07 '13 at 12:36

Igor%20Escobar's gravatar image

Igor Escobar
11

Which class is it?

(Oct 07 '13 at 12:38) chilkat ♦♦

Crypt class!

(Oct 07 '13 at 12:39) Igor Escobar

aes = Chilkat::CkCrypt2.new() aes.UnlockComponent("anything for 30-day trial") // False

(Oct 07 '13 at 12:40) Igor Escobar

Here's a temporary unlock code valid until 30-Oct-2013

T10302013Crypt_7ANXyuvxGV85

(Oct 07 '13 at 12:46) chilkat ♦♦

Worked like a charm! Thank you!

(Oct 07 '13 at 12:48) Igor Escobar

You're very welcome. :)

(Oct 07 '13 at 13:00) chilkat ♦♦
showing 5 of 6 show all
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1
×1

Asked: Sep 17 '13 at 03:52

Seen: 1,613 times

Last updated: Oct 07 '13 at 13:00

Related questions

powered by OSQA