login about faq


I do not see any documatation in the notes or on the forum about the dependencies of the 32bit Activex DLLs (ver 9.5.0) on Visual C++ Redistributable?

Do I need to install any Visual C++ Redistributable on target computers and what version is required?


Sorry, if post appears twice. I don't see the original post after account activation!

asked Mar 27 '14 at 00:16

kitkat's gravatar image


edited Mar 27 '14 at 00:17

The Chilkat ActiveX's are built using Visual Studio 2008 (VC++ 9.0).

This was chosen because it is the oldest version of Visual Studio that supports features required to pass certain security tests by Microsoft, such as /SAFESEH /NXCOMPAT.

The reason the oldest version of VC++ is chosen is because it is the most likely to be already-installed on any given machine. In other words, it will be rare to find machines without it (as opposed to building the ActiveX's with VS2013, for example).


answered Mar 27 '14 at 10:34

chilkat's gravatar image

chilkat ♦♦

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Mar 27 '14 at 00:16

Seen: 1,089 times

Last updated: Mar 27 '14 at 10:34

powered by OSQA