login about faq

Hi Chilkat Support,

I am using the 9.5.0.36 VC++ 9 win32. I encounter an issue regarding HTTP Request.
Prior to GET, I have successfully send a HTTP POST with params as shown below :

    Request.put_HttpVerb("POST");
    Request.put_Path("/member.php?mod=logging&act....");

Request.AddHeader("Accept","text/html, application/xhtml+xml, */*");
    Request.AddHeader("Referer","xxxxxxxxxxxx");
    Request.AddHeader("Accept-Language","zh-CN");
    Request.AddHeader("User-Agent","Mozilla/5.0 .... like Gecko");
    Request.AddHeader("Content-Type","application/x-www-form-urlencoded");
    Request.AddHeader("Host","xxx.xxx.xxx");
    Request.AddHeader("Connection","Keep-Alive");
    Request.AddHeader("Pragma","no-cache");

Request.AddParam("fastloginfield","username");
    Request.AddParam("username","xxxxxxxxxx");
    Request.AddParam("cookietime","2592000");
    Request.AddParam("password","xxxxxxxxxx");
    Request.AddParam("quickforward","yes");
    Request.AddParam("handlekey","ls");

Response = Http.SynchronousRequest("xxxxx",xxx,bSsl,Request);

Taken from session log :

POST /member.php?mod=logging&act...... HTTP/1.1
Content-Type: application/x-www-form-urlencoded
Accept: text/html, application/xhtml+xml, /
Accept-Language: zh-CN
User-Agent: Mozilla/5.0 (MSIE 9.0; Q.....like Gecko
Connection: Keep-Alive
Referer: http://xxx.xx.xx/
Pragma: no-cache
Cookie: xxx.......
Host: xxx.xxx.xxxx
Content-Length: 132

fastloginfield=username&username=xxxx&cookietime=2592000&password=xxxx&quickforward=yes&handlekey=ls

After this, I did a HTTP GET as shown below :

    Request.put_HttpVerb("GET");
    Request.put_Path("/");

Request.RemoveHeader("Content-Type");
Request.RemoveHeader("Pragma");

Request.RemoveAllParams();

Request.AddHeader("Accept","text/html, application/xhtml+xml, */*");
Request.AddHeader("Referer","");
Request.AddHeader("Accept-Language","zh-CN");
Request.AddHeader("User-Agent","Mozilla/5.0 .... like Gecko");
Request.AddHeader("Host","xxx.xx.xxx");
Request.AddHeader("Connection","Keep-Alive");

Taken from session log, params are sent too !
 
GET / HTTP/1.1
Accept: text/html, application/xhtml+xml, /
Accept-Language: zh-CN
User-Agent: Mozilla/5.0 ..... like Gecko
Connection: Keep-Alive
Referer: http://xx.xx.xx/
Cookie: xxxxx
Host: xxx.xxx.xx

fastloginfield=username&username=xxxx&cookietime=2592000&password=xxxx&quickforward=yes&handlekey=ls

Hence, is this a bug ?

Please advise.

Thanks.

Best regards Dragon

asked May 05 '14 at 07:40

dragon's gravatar image

dragon
333711

edited May 05 '14 at 07:41


This is fixed now in v9.5.0.38.

See http://www.cknotes.com/v9-5-0-38-micro-update-trustedroots-objectclass-added-and-other-various-fixes/

I will update the download for VC9 ASAP..

link

answered May 06 '14 at 10:49

chilkat's gravatar image

chilkat ♦♦
11.8k316358421

Hi Chilkat Support,

Thank you very much !

Best regards Dragon

link

answered May 06 '14 at 17:28

dragon's gravatar image

dragon
333711

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×186
×9

Asked: May 05 '14 at 07:40

Seen: 3,056 times

Last updated: May 06 '14 at 17:28

powered by OSQA