login about faq
1
1

ChilkatLog:GetFile:DLLDate:Aug 15
2013 ChilkatVersion:9.4.1.42
UnlockPrefix:Anything for  30-daytrial
Archicature:Little Endian; 32-bit
language:IOS Objective-C
VerboseLogging:0  hcCurDate:fri, 06
Jun 2014 16:15:39 +0530 hcExpire:
11/2013 ProgressMonitoring: enabled:no
heartbeatMS:0
sendBufferSize:65536--progressMonitoring
AutoGetSizeForProgress:0
localFilename:/user
/abc/Library/Application
Support/iphone
simulator/7.0/application/3445665656
document{343454455}_0555.png
GetFileToOutput_1
getfiletooutput2_1:modeZ:0
BinaryMode:1 Passive  transfer mode
setuppassiveDataSocket2: No socket
exist for sending (2b) failed to send
PASV/EPSV  command. no longer
connected to FTP server. setup
passiveDataSocket
faild.--setupPassiveDataSocket2 
failed to setup passive data socket
for getfile
--getFileToOutput2_1--getFileToOutput_1  TotalTimeMS:Elapsed time:0 millisec
Failed. GetFile ChilkatLog.

asked Jun 06 '14 at 10:10

Gopal's gravatar image

Gopal
16123

edited Jun 07 '14 at 01:44


Format the LastErrorText in "pre" tags so that it's readable...

link

answered Jun 06 '14 at 10:22

chilkat's gravatar image

chilkat ♦♦
11.8k316358421

i have added "pre" in my error text.

(Jun 06 '14 at 10:35) Gopal

Still not readable -- you'll need to maintain the line endings so that it's not one giant long line.

(Jun 06 '14 at 10:42) chilkat ♦♦

now you can check again please.

(Jun 07 '14 at 01:46) Gopal

Please give me suggestion for that it Thanks.

(Jun 07 '14 at 09:39) Gopal

First, you are using an old version of the library, so I recommend updating to the latest version and trying again.

If the problem persists, can you give us some more information about what you are trying to do that is failing? Maybe a code sample? All we have now is an error log.

That said, the error indicates that there is no connection to the server. So have you tested for success on previous method calls to make sure that an earlier call hasn't disconnected you from the server for some reason?

link

answered Jun 07 '14 at 12:16

jpbro's gravatar image

jpbro ♦
1.1k2618

Here my code what i am doing for get the connection and write the file in document directory please have a look.

     self.chilKatFTPManager=[[CkoFtp2 alloc]init];
     self.success= [self.chilKatFTPManager UnlockComponent: @"Anything for 30-day trial"];
     if (success1 != YES) {
     [strOutput appendFormat:UNKOWNN_DOWNLOAD_ERROR,remoteFilename];
      [self showChilkatError:strOutput];
      }
    self.chilKatFTPManager.Hostname = appdelegate.strFTPHost;
    self.chilKatFTPManager.Username = strFTPUserName;
    self.chilKatFTPManager.Password = strFTPPassword;
    [self.chilKatFTPManager setSkipFinalReply:YES];
    [self.chilKatFTPManager setPassive:YES];
    [self.chilKatFTPManager setPort:[NSNumber numberWithInt:21]];
    self.success2 = [self.chilKatFTPManager Connect];
    if (success2 != YES) {
      [self showChilkatError:strOutput]; }
    else
    {
     BOOL success= [self.chilKatFTPManager GetFile:remoteFilename localPath:filePath];
    }

link

answered Jun 10 '14 at 02:02

Gopal's gravatar image

Gopal
16123

It appears the connection is being dropped before Passive mode can be set. Some things to try/consider:

  1. Did you upgrade to the latest version of the library and try again?
  2. Set VerboseLogging = 1 to get more information in the LastErrorText property, and then repost it here in <pre> tags.
  3. The documentation for SkipFinalReply says only to use if advised by Chilkat to do so. Are you sure your FTP server requires this property to be set?
link

answered Jun 10 '14 at 11:29

jpbro's gravatar image

jpbro ♦
1.1k2618

Then what should i do for connection?it should not break.

(Jun 11 '14 at 01:48) Gopal

The connection will only break for one of a few reasons: a bug in the Chilkat library, a bug in your code, bad configuration of the properties in your code, the server decides the connection should be closed for some reason, or network hardware or configuration problem.

Let's assume that your network hardware and configuration is correct. Let's also assume that your code is bug free.

That leaves a possible bug in the Chilkat library, which is why I suggested upgrading to the latest version (9.5.X). Did you do this and try again?

It also leaves bad configuration of the object properties. I asked if you were instructed to set SkipFinalReply:YES by Chilkat, since the documentation states that you should only do so if instructed. If not, have you tried with SkipFinalReply:NO?

Lastly, it's possible that the server is deciding to close the connection due to conditions that are not clear (security configuration? bug on the server?). This is why I suggested setting VerboseLogging:YES and reposting the LastErrorText contents at the point of failure, as there may be more information that will help diagnose the problem.

link

answered Jun 11 '14 at 08:05

jpbro's gravatar image

jpbro ♦
1.1k2618

I have added latest version of chilkat library and as you suggested setting VerboseLogging:YES,i did .but also having same problem and 'ChilkatLog:GetFile:DLLDate:Aug 15 2013 now replaced with letest date of version of error log.now please suggest me what should i do?

(Jun 11 '14 at 08:18) Gopal

Are you sure the content of LastErrorText is the same other than the date? VerboseLogging:YES is supposed to include extra information (if available). If it's not different, then unfortunately I'm out of ideas and you might have to wait to see if Chilkat has any other suggestions.

(Jun 11 '14 at 16:12) jpbro ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×98
×94
×34
×8
×6

Asked: Jun 06 '14 at 10:10

Seen: 1,385 times

Last updated: Jun 11 '14 at 16:12

powered by OSQA