login about faq

What would prevent a person logged into Windows as an administrator from registering the Chilkat ActiveX DLL's? We are receiving more and more tech support questions regarding this issue. Has Microsoft changed the way security works in some versions of Windows or have they released some Windows updates that change how security handles DLL registration?

asked Oct 07 '14 at 12:00

JoeMa's gravatar image



answered Oct 11 '14 at 20:52

Americo%20Belinha's gravatar image

Americo Belinha


The OP mentioned that they were able to manually register the DLL on a computer where the installer failed to register it. I don't think this would be possible if the VC++ 9 library wasn't installed on the system, would it?

(Oct 13 '14 at 08:46) jpbro ♦

My bad, when I read : "We even did a Remote Assistant session with one user and could manually register the DLL's." I assumed "couldn't". I don't use InstallShield. I use Inno Setup. When developing the Inno Setup Project, I remember having several options for registering DLL's. I assume Installshield shall have similar. My customers download frequently from my website the .EXE's for installing Demos and upgrading. Besides the occasional VC++2009 problem on older systems when passed from chilkat 9.4.1 to 9.5.0 version, everything went smooth.

(Oct 13 '14 at 09:54) Americo Belinha

Sorry, I wasn't trying to sound persnickety - I was just wondering how the answer got accepted when it didn't appear to fit the facts (maybe the OP supplied misleading information).

(Oct 13 '14 at 10:48) jpbro ♦

First, it is very difficult to know what is wrong without some kind of error message or error code. If you have this information, please supply it.

Second, why are your users manually registering DLLs anyway? It seems a bit unusual. Does your software not have an installation package?

Other Questions:

  • Are you 100% sure that the users have admin access, and they are trying to register from an elevated command prompt?
  • Are they using regsvr32 to register the DLL, or some other tool?
  • Have they placed the DLL in the proper System folder if it is a 64-bit OS?

answered Oct 08 '14 at 12:18

jpbro's gravatar image

jpbro ♦

We are software company so we understand how DLL's are registered for our software. We use Installshield and it handles the registrations of the DLL's. But they do not register for some users who are administrators. We even did a Remote Assistant session with one user and could manually register the DLL's. This is a security issue with Windows but we do not understand what is causing the problem.


answered Oct 08 '14 at 13:38

JoeMa's gravatar image


What makes you sure it is a Windows security issue? Did you get a permission denied error, or some other

Does InstallShield create a log? If so, does it include an error message when the registration fails? If so, what is the message?

Also (again), are you sure the DLL is in the correct Windows System folder if it is a 64-Bit system?

Lastly, is it just the Chilkat DLL that is failing to register?

(Oct 08 '14 at 13:47) jpbro ♦

We have a large user-base (20K plus users) and have been distributing our product for 9 years. Only recently (in the past few months) has this issue been reported by some users. So if its not a Windows security issue, what else could it be? That is why we logged this question here.

Installshield does not create a log or report any errors after the install completes. But as soon as the user tries run our software, the DLL's cannot be accessed as though they were never registered. CREATOBJECT() simply cannot find them in the registry.

The Chilkat DLL's are saved in the same folder as our software (as suggested by Chilkat Software).

We do not ship our software with any DLL's other than the 5 Chilkat DLL's in question.

Does anyone have a suggestion or thought as to why only some users are now experiencing this issue? From our point of view something has changed with Windows security or an external program is affecting access to the users registry.


answered Oct 08 '14 at 18:22

JoeMa's gravatar image


Is there any common thread between the systems where the problem is occurring? Are they the same OS version, or are they all 64-bit/32-bit, or perhaps they all have the same antivirus software? I mentioned antivirus because I've had a situation before where a false positive detection caused on to block access to a DLL resulting in a similar problem to what you are experiencing.

Are the users running the InstallShield wizard themselves, or is it part of an automatic-update solution?

(Oct 08 '14 at 18:27) jpbro ♦

No common thread that we can see. Different versions of Windows, some using antivirus, some who do not have any AV installed. The users always download and run the setup themselves. It is an EXE Installshield installer.


answered Oct 08 '14 at 19:04

JoeMa's gravatar image


You should ask one of the users that is having the problem to try running the InstallShield EXE with logging parameters. This will hopefully give you some more information to determine what is wrong.

See this ServerFault Question for command line logging parameters for IS

(Oct 08 '14 at 22:09) jpbro ♦

Also, are you using the latest version of InstallShield to create your installation EXE? Maybe there's been a bug fix in a more recent version than you are using?

(Oct 08 '14 at 22:10) jpbro ♦

jpbro: Our software installer is not the problem. Our software is downloaded by hundreds of people everyday. Yet only a small number have reported a problem related to the Chilkat DLL's. So we are looking for answers from others who may have experienced this issue and discovered the cause and solution. If you haven't experienced this issue you are not likely to offer a solution.


answered Oct 09 '14 at 21:25

JoeMa's gravatar image


Your software installer may or may not be the problem - you haven't defined the problem (other than very generally that the DLL(s) aren't being registered) because you haven't even given us the very basic benefit of an error message or code.

Whether it works for hundreds of people but not a few, or a few people but not hundreds - there must be some commonality between the non-working instances that is causing the problem.

You seem stuck on the idea that it's a Windows security change, but you haven't determined if the problem computers all have the same recent security update installed?

(Oct 09 '14 at 21:31) jpbro ♦

And as mentioned earlier I have experienced the same problem - which was what my line of questioning about antivirus software (and automatic updates) was about. I had an issue where AV software was blocking registration of a DLL based only on heuristics when the DLL was distributed via an automatic update channel and registered via a Windows Service. In all other cirucmstances the DLL installed and was registered fine.

(Oct 09 '14 at 21:34) jpbro ♦

Anyway - if you aren't going to offer any concrete evidence of the problem, and refuse to do even the most basic research by getting your installation to provide a log (which should at least give us an error code to work with), then why are you even asking the question? How do you expect anyone to help with such a general question a "My DLL doesn't install sometimes, but usually does. Why?"

(Oct 09 '14 at 21:35) jpbro ♦

We invite any others to post comments regarding any experience with this issue. To recap:

  1. All users are logged into Windows as an administrator
  2. User running XP, Vista, Windows 7, and Windows 8 have all recently reported this issue
  3. Many have tried uninstalling all antivirus software to no avail
  4. Many have tried running the setup and the software using "Run as administrator"
  5. Most users can download and install our software with no DLL issues so this affects a small number of users only

answered Oct 09 '14 at 21:34

JoeMa's gravatar image


edited Oct 14 '14 at 16:03

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Oct 07 '14 at 12:00

Seen: 2,446 times

Last updated: Oct 14 '14 at 16:03

powered by OSQA