login about faq

Hi there, Using ftp2 in iOS app. Works fine on device, but in the sumulator I get the linker error shown below. I wasn't sure what libchilkatIos.a to add, so I added then all! For all the different architectures. Works fine on actual hardware but not in Simulator. Any ideas out there? Rob.

ld: warning: ignoring file /Users/Rob/Downloads/chilkat-9.5.0-ios/lib/arm64/libchilkatIos.a, file was built for archive which is not the architecture being linked (i386): /Users/Rob/Downloads/chilkat-9.5.0-ios/lib/arm64/libchilkatIos.a
Undefined symbols for architecture i386:
  "_OBJC_CLASS_$_CkoFtp2", referenced from:
      objc-class-ref in ScannerViewController.o
ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)

asked Apr 13 '15 at 07:23

Robby's gravatar image


The error message shows you're linking against:

However, you're trying to link for the simulator and in that case you certainly don't want the arm64/libchilkatIos.a

If you look, you'll find that the /Users/Rob/Downloads/chilkat-9.5.0-ios/lib/i386/libchilkatIos.a library is present. Make sure to link with that one..


answered Apr 13 '15 at 08:35

chilkat's gravatar image

chilkat ♦♦

So I am still struggling with this. If I remove all the libs from the frameworks, and just add the lib from i386, I still get the error saying that the linker is using the arm64 lib. If I remove all the libs I get symbols not found as expected. But then regardless of which lib I add in I get the message that the lib is arm64 and not able to be used. Does that make sense? I've tried adding the libs in the frameworks section with the same result. Regardless of which lib I add, Xcode reverts to the arm64 one! This is driving me nuts! Cheers Rob.

(Apr 16 '15 at 03:54) Robby

No idea how I fixed this, but if I moved the location of the lib folder to somewhere else, deleted the old folder, then added the libs from the new location, everything works fine! Wow XCODE! I have a question about how to support arm64 and armv7 in an application when submitting to app store, but I'll save that for a new question when the time comes. Maybe the app store will allow uploading separate apps for different archs.


answered Apr 16 '15 at 04:01

Robby's gravatar image


Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: Apr 13 '15 at 07:23

Seen: 920 times

Last updated: Apr 16 '15 at 04:01

powered by OSQA