login about faq

I have tested the below suggestion locally which works perfectly however when I deploy my app to a test server I get the following error.

Could not load file or assembly 'ChilkatDotNet4.dll' or one of its dependencies. The specified module could not be found.

I have checked that the ChilkatDotNet4.dll is on the server and it is. If I change my application to using the ChilkatDotNet2.dll it all works without issue. Would this be due to the trial version of the DotNet4 dll as I am waiting for a activation key or is there some other issue?

asked Jun 18 '12 at 10:17

chilkat's gravatar image

chilkat ♦♦
11.8k316358420


The Chilkat .NET assembly is a mixed-mode assembly, meaning that the internal implementation is written in C++ and compiles to native code. Given that it is created using Visual Studio 2010 (using VC++), the Microsoft VC++ 2010 runtime libs need to be present on the computer. You don't see the problem with the 2.0/3.5 Framework because that Chilkat assembly is compiled/linked with Visual Studio 2005, and virtually every Windows computer in existence already has the VC++ runtimes for that version already installed. I'm sure in due time the same will be true for the 2010 runtimes.

The VC++ 2010 redistributables can be downloaded and installed from:

x86 Microsoft Visual C++ 2010 Redistributable Package
x64 Microsoft Visual C++ 2010 Redistributable Package

link

answered Jun 18 '12 at 10:23

chilkat's gravatar image

chilkat ♦♦
11.8k316358420

edited Jun 18 '12 at 10:26

Worked for me. Make sure if your web worker (w3wp/application pool) is set for 32-bit mode (Enable 32-bit under advanced settings) that you install the 32-bit version of the C++ redis.

(Jul 23 '14 at 00:32) chrisgrasp

Thank you, I appreciate the reply.

link

answered Jul 13 '12 at 11:13

J%20Trahair's gravatar image

J Trahair
1234

Just installed x64 Microsoft Visual C++ 2010 SP1 Redistributable Package and I still get the same error. Any other ideas?

link

answered Sep 24 '12 at 14:07

pboisso's gravatar image

pboisso
1

Maybe the ChilkatDotNet4.dll itself could not be found. Make sure it's in the same directory as your app's .exe (or installed in the GAC if your app is a Windows Service).

(Sep 24 '12 at 15:40) chilkat ♦♦

it's in the /bin directory of our web app. I don't recall installing the dll in the GAC for our win2k3 web servers (this is on a win2k8 server now).

(Sep 24 '12 at 17:15) pboisso

Is your IIS running in 32-bit mode? (which is very common because I've read that it can be more efficient than 64-bit mode.) If so, then install the 32-bit VC++ 2010 redist.

(Sep 24 '12 at 18:04) chilkat ♦♦

Ah ok, yes that is it. I installed 64-bit version of the VC registribuable package, do you know if we can install the 32 and 64-bit version side-by-side? Thanks again.

(Sep 24 '12 at 21:21) pboisso

Yes, you can

(Sep 24 '12 at 21:31) chilkat ♦♦

Thanks for the great support, everything back on track!

(Sep 25 '12 at 08:53) pboisso
showing 5 of 6 show all
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×62
×31
×18
×14

Asked: Jun 18 '12 at 10:17

Seen: 49,606 times

Last updated: Jul 23 '14 at 00:32

powered by OSQA