login about faq

Hi We use Chilkat in our software solution and there is an issue when connecting to an exchange server via EWS When an email comes in that has attachments (visible on exchange via OWA) the attachments are not displaying in the product and i wondered if this is due to the default content type in exchange being set to mimehtml as opposed to mimehtmltext? is there a known issue with certain mail formats?

asked Aug 07 '15 at 11:07

snagsy1980's gravatar image

snagsy1980
11


Are you aware that the Chilkat mail class divides the attachments up into several categories depending on their type and/or usage?

The methods available are:

  • GetAttachment (the easiest to understand)
  • GetAttachedMessage (message/rfc822 attachments)
  • GetRelatedData (attachments used inline, typically stylesheets or images used in html mail bodies)
  • GetAlternativeBody (probably not your use case, but could also be considered somewhat of an attachment, since it is also just another mime part)

Maybe your missing attachment is one of these?

link

answered Aug 13 '15 at 13:45

coeamyd's gravatar image

coeamyd
261

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×184

Asked: Aug 07 '15 at 11:07

Seen: 1,636 times

Last updated: Aug 13 '15 at 13:45

powered by OSQA