login about faq

After setting the proxy properties, the proxy site denied the connection Ex. // after http creation and unlock http.ProxyDomain = "proxyaddress.com";

http.ProxyPort = 3128;

string html = http.QuickGetStr("sometext.txt");

// in html get the next page, instead the file contents of sometext.txt... // the contents of html is like

This Page Cannot Be Displayed Authentication is required to access the Internet using this system. A valid user ID and password must be entered when prompted. Notification codes: (1, PROXY_AUTH_REQUIRED)

How can i set the correct credentials to go through this kind of proxy? Any ideas?

Thanks

asked Oct 23 '12 at 11:28

Kylix's gravatar image

Kylix
16112


Set the http.ProxyLogin and ProxyPassword properties.

link

answered Oct 23 '12 at 15:27

chilkat's gravatar image

chilkat ♦♦
11.8k316358421

Same result, helpdesk dont have a user/pwd to provide, The proxy is using NTLM authentication, they set IE without user/pwd and works with browsers, except through code using http class.

(Oct 23 '12 at 16:31) Kylix

Try setting the ProxyLogin and ProxyPassword properties equal to the keywords "default". This will cause Chilkat (internally) to use Microsoft's SSPI for NTLM, and it will use the current process's user credentials for authentication.

(Oct 24 '12 at 10:48) chilkat ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or __italic__
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×186
×28
×24

Asked: Oct 23 '12 at 11:28

Seen: 2,038 times

Last updated: Oct 24 '12 at 10:48

powered by OSQA